Extended Maintenance Unavailability
Incident Report for Labflow
Resolved
Maintenance has been completed, Labflow is now available.
Posted Jul 06, 2023 - 14:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2023 - 13:39 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 06, 2023 - 13:10 UTC
This incident affected: Labflow App.